JJSTYLER








  1. Oh, there isn't? Sorry! Thought there would be.

  2. No there is! All sorted! Thanks!!

  3. Man, I miss the 90s! No firmware updates or patches required!

  4. if you only care about the next 5-10 years then you dont need to worry

  5. 5 - 10 years us just a number. I’m still playing MEGADRIVE and SNES games I’ve had since the 90s! But like I say, they will always work!

  6. Yes, you can switch between the update channels and revert back to 1.3.6 stable if you decide you no longer want to use beta/testing firmware.

  7. Has anyone got a download for it yet?

Leave a Reply

Your email address will not be published. Required fields are marked *

Author: admin